Scheduled Maintenance on phone system

Incident Report for Funio - System Status

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 14:47 EDT

Investigating

We will be performing scheduled maintenance on our phone system.

During this time, users could expect interruption with Funio phone service.

We apologize for any inconvenience this may cause.
Posted Mar 19, 2026 - 11:34 EDT
This incident affected: Support Platform (Phone System).