Critical: Slowness on our chat and email support platform
Incident Report for Funio - System Status
Resolved
This incident has been resolved by our provider and everything is back to normal now.
Posted May 29, 2024 - 12:58 EDT
Investigating
Our provider is currently investigating an issue on our chat and email support platform that is causing slowness and downtime.
More details to come.
Thank you for your understanding.
Posted May 29, 2024 - 12:18 EDT
This incident affected: Support Platform (Discussion and E-mail Platform).