Issue with the Funio customer Hub
Incident Report for Funio - System Status
Resolved
Everything is back to normal now.
It was a network issue at our provider's data center that was causing intermittent connection errors.
Posted Dec 13, 2023 - 15:56 EST
Investigating
We are investigating an issue with the Funio Customer Hub. Connection is intermittent.
More details to come.
Thanks for your patience.
Posted Dec 13, 2023 - 09:41 EST
This incident affected: Customer Portal.