Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 11, 2023 - 18:01 EST
Scheduled
We will be changing the IP addresses of our Funio website, Funio Customer Hub, and Domain Forwarding Service this evening at 6:00 p.m. This change may result in some downtime, but it should not be extended downtime.
If you have any questions, do not hesitate to contact us.
Posted Dec 11, 2023 - 16:00 EST
This scheduled maintenance affected: Customer Portal and Corporate Website.