Issue with our website funio.com

Incident Report for Funio - System Status

Resolved

This incident has been resolved.
Posted Apr 24, 2023 - 16:54 EDT

Monitoring

Our site funio.com is accessible now. A fix was implemented and we are monitoring the situation.
Posted Apr 24, 2023 - 12:13 EDT

Investigating

We are currently investigating an issue with our website funio.com

More information will be available shortly.
Posted Apr 24, 2023 - 10:46 EDT
This incident affected: Corporate Website.