Critical: Funio website and customer portal unavailable

Incident Report for Funio - System Status

Resolved

Our provider fixed the network issue and everything is back online now.
Posted Mar 30, 2026 - 15:10 EDT

Investigating

Our provider is currently investigating a network issue that is affecting our website Funio.com and our customer portal (Funio Hub).

More details to come.
Thank you for your patience.
Posted Mar 30, 2026 - 14:26 EDT
This incident affected: Customer Portal and Corporate Website.