Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 23, 2026 - 08:00 EDT
Scheduled
As part of a major modernization work at our infrastructure partner, the backup servers will be moved to a state-of-the-art data center. The backup service will be unavailable for most of this maintenance window.
Posted Apr 22, 2026 - 13:46 EDT
This scheduled maintenance affects: Shared Hosting.