Critical: Funio website is unavailable
Incident Report for Funio - System Status
Resolved
This incident as been resolved.
Posted May 30, 2024 - 10:51 EDT
Investigating
We are currently investigating an issue with our website Funio.com

Thank you for your patience.
Posted May 30, 2024 - 09:40 EDT
This incident affected: Corporate Website.